Does It Work in Newest Version of P3Dv3?

Discuss everything about the Fairchild Swearingen Metroliner here.

Does It Work in Newest Version of P3Dv3?

Postby signmanbob » Thu Jan 05, 2017 6:07 am

Hello, I purchased the Metroliner for P3D, then seen that it is for P3Dv.2, which is the long outdated version of P3D.
Will the Metroliner work with P3Dv.3.4?

Thank you,
Bob
signmanbob
 
Posts: 1
Joined: Wed Nov 21, 2012 6:12 am

Return to Metroliner III

Who is online

Users browsing this forum: No registered users and 1 guest

cron